Wednesday, January 30, 2008

Iconbar Plugin Update 2

Its here!! For those who are not happy with the black background on the Iconbar plugin, or are willing to have their own notification icons, this update to the plugin is just meant for that. I have finally completed detaching the icons from the dll. All icons, including the background, are now read from .png files, meaning, if you don't like an icon, just change the file.

Make sure you have a running version of the plugin. If not, then see Colored Iconbar Plugin for instructions and then head back here to perform the update.



1. Change over to a different theme, one not using the plugin. Reboot.

2. Download this zip file - Rinku Iconbar Plugin Update 2. Using ActiveSync, copy the contents of the Iconbar folder in the zip file to \Windows on your phone.

3. Change back to the original theme.

The icon file names are self explanatory. Each file begins with the prefix CHome_Iconbar_. Just change the appropriate file to change an icon, or the background. The background image in the zip file is for the T-Mobile Default theme. Note that all icons are 20x20 32-bpp PNG files, except for the background image which is 240x27 and four other files which are 6x5. I had to restrict any changes to the battery meter icon since its drawn dynamically depending on the battery strength left.

TIP: If you want your icons to appear the same on any background, make sure you set the proper transparency levels on the pixels on the edges of the icons. Use the alpha channel!!

So let your creativity loose and please do let me know what you come up with.

44 comments:

Anonymous said...

Using it now,
Works perfectly.

As always man, thanks!

Anonymous said...

What do I need to change to have the entire bar completely transparent? I changed the background image to be transparent but then the background turns black if you select the theme.

Rinku said...

The transparency issue has been brought to my attention. I am packaging an update with landscape support and the transparency issue resolved. Please check back in two days!

Anonymous said...

Is here any chance to have this plugin working on QQVGA?

Rinku said...

It should but half of the icons will be offscreen. The plugin is intended for the QVGA resolution, so in the QQVGA you would only see half of the iconbar - rest will get drawn outside screen area! I didnot think of QQVGA while developing the plugin since its hard to fit so many notification in a restricted area.

Mike said...

Hi Rinku,
Thanks for this great icon bar, i loaded the original one on my samsung I600 landsape, it is runing great, but when i updated to the 2nd update, couldn't get the landscape, and one more thing if it is possible, to make it systen icon bar, since it slow the phone dramatically while scrolling thru menu, Thanks again for the great job.

Rinku said...

Mike,

Which update are you refering to? The files from this blog only have portrait support...the recent one from Modaco has landscape support in addition. I did not understand what you meant by system icon bar? Could you please elaborate on that?

Anonymous said...

can you make it to have transparent background to look better in WM6.1 ROMs??

Rinku said...

There is a update at Modaco - http://www.modaco.com/content-page/264066/Colored-Iconbar-Plugin/page/40/ with transparent background support.

Anonymous said...

Is there a way to add 3G and HSDPA as data options? I am using this on a Moto Q9h and it works great, except it does not show if I have 3G coverage.

Thanks!

Rinku said...

There isn't any for now. However, I have decided to add some more notifications, including other network types!

Anonymous said...

Is GPS included in the other notifications you plan on adding? If not I would like to request it.

Thanks!

Rinku said...

GPS..hmm!! As far as I know the Shadow does not come with a GPS...what do you have in mind?

Anonymous said...

If you see this post, http://www.modaco.com/content/Smartphone-Standard-News/263776/Finally-the-Microsoft-utility-for-configuring-GPSID-on-Smartphone/, you can see that a GPS icon is shown on the Motorola Q9h indicating the status of the internal GPS. It would be great if this was passed through.

Rinku said...

Okay, I am assuming then that you own a Moto Q9h. The phone I have, the T-mobile Shadow, does not have an in built GPS unit :( The problem I would face in adding it is the lack of a testing bed, besides trying to figure out the GPS settings in the registry. Anyway, I shall try to do it and hopefully someone owning a device with inbuilt GPS would volunteer to test it :)

Lainie said...

heyyyyy i need your help.. it would be greatly appreciated. i was trying to follow everything you said, but for some reason nothings working and i'm afraid im going to break my phone. i'm new at this. please email me at babeegurlie521@gmail.com! i don't really check this all that much but it would be a great help. thanks a lot!

Anonymous said...

Hello Rinku,
Thx for your work on this plugin.
Do you think I can change the battery meter icons by adding 5 or 6 pictures, just like the strenght signal ?
I can't find the battery icons on windows folder ...
How can I make them appear ???
I want to change all icons
Exemple of my theme http://img90.imageshack.us/img90/51/ffqw0.png
Thanks for your answer ;-)

Anonymous said...

Are you willing to share your icons? I like the look of your theme and would like to use it. Maybe post them on the Modaco forum, http://www.modaco.com/content/HTC-Juno-Phoebus-Juno-MoDaCo-com/264066/Colored-Iconbar-Plugin/

Anonymous said...

Hello, you can download my theme here : http://www.nectun.com/details_skin.php?id_menu=2&langue=fr&id_skin=5916&id_type_tel=15#18834
You will find links to my icons zip ...
Rinku, have you seen my demand ?

Anonymous said...

Good day,

I tried installing this on my Blackjack II, and it doesn't show up at all. I've checked, and the required entries are not in the registry. I'm not sure how to enter them manually. The link I saw in a post for the cab file doesn't work.

Thanks

Anonymous said...

Hello,

This theme won't work on your phone, because it's not the same screen resolution (240x320 vs 320x240)
Sorry

Rinku said...

March 31:

It was nice seeing people are modifying the icons. I like the ones at imageshack more than mine. The battery icons are for now hard wired inside the plugin. But I see no reason why that should me. I shall be working on a couple of updates on the plugin...will make it point to free the battery icons.

April 15:
A broken link...hmm!! Freddy must have moved the files on his server. If you still have not located the file, try this - http://freddyreyes.com/forums/index.php?topic=287.0

If resolution is a problem, then you will have to find the files I posted at Modaco - http://www.modaco.com/content-page/264066/colored-iconbar-plugin/page/40/

Anonymous said...

It was nice seeing people are modifying the icons. I like the ones at imageshack more than mine. The battery icons are for now hard wired inside the plugin. But I see no reason why that should me. I shall be working on a couple of updates on the plugin...will make it point to free the battery icons.

Thank you for working on it ...
I've made a few theme with your plugin, and I like it. You can see them on http://www.nectun.com.
My name is cookie (for exemple : http://www.nectun.com/details_skin.php?langue=fr&id_skin=5980&id_type_tel=15 )

See you soon ;-)

Rinku said...

Cookie,

The themes were nice. It would be great if you can seperate out the icons for the plugin and share with other Shadow users.

Anonymous said...

Rinku,

You can find all the zip files in the "fichiers joints" at the top of each of my theme on nectun.com (galerie de cookie)
If you explain to me to post them here, or how to give you the files, it will be with pleasure ...

;-)

Rinku said...

Cookie,

I would really appreciate if you can send me the files over to rinkud@gmail.com....having some problems extracting the files off the cab at nectun. Thank you.

Anonymous said...

Hi Rinku,

It's done ;-)

Cookie

Anonymous said...

Hello Rinku.... thee are plenty users like me (HP IPAQ 512 Voicemessenger) that is QQVGA and if you dont have the time doing it yourself, I wouldn't mind doing it myself to adjust it. If you like, send me the sources to ollesoasch@gmail.com. It would help greatly NOT to re-invent the wheel. I will update you, of course with the resuslts. Thanks. Jake

Anonymous said...

Hi,

There is a bug between Iconbar plugin and Fring plugin, they use the same GUID :
{B06A8DAB-E148-40d5-BE8F-3C494ABF3046}

Could you correct this ?

Bye.

B said...

Hello Rinku,
I'm fairly new to this, I just got an HTC Shadow about 2 weeks ago. But I'm pretty sure I've loaded everything correctly and yet none of the plug-ins seem to be working correctly. The Neo Dockstation isn't working at all, and neither is the colored icon plugin. I've unlocked the apps, I've made the changes to cmhome.home.xml and saved it into \windows and \application data\home, i've created the new key in CeRegistryEditor and created the new string value, i've loaded the iconbarplugin.dll into \windows, and i've tried going through both iconbar plugin updates, both with no success. Do you have any ideas as to what could be wrong and how to correct the issues? As is there are no icons showing on the T-Mobile Default theme.

Thanks, Brett

B said...
This comment has been removed by the author.
B said...

Good morning,
I'd like to make a correction to my above post. The weather dock seems to be working correctly. I didn't realize that I was trying to configure it from the T-Mobile Default theme and not the NeoDock theme. However, the color status dock still doesn't work in the Neo Dock theme, and the color icon plugin doesn't work in the T-Mobile Default theme. I have no interest in the shadow dock or the WMP dock, so I'm not sure if they're working or not in the neodock as I had no reason to try them out. I assume the shadow dock works correctly as that is the default for most themes. But right now I'm most interested in getting the color icon plugin working, so far with no such luck. Any suggestions??

pudgedaddy said...

Rinku, Is there an update you're going to do to show an icon for bluetooth stereo headphones? Or am i missing something?

Rinku said...

Release of the source code is pending for a while...I am willing to do it, but of course I would want to clean it up before doing so. Let me see if I can hurry it up!

Rinku said...

The GUID issue has been brought to my attention. It seems the Fring guy too made the same mistake I did - using the sample GUID from the Microsoft sample plugin. I just have been lazy to rectify it, but guess it needs to be done now. Thank you.

Rinku said...

B,

What do you see when you load the iconbar from NeoDock?

Rinku said...

pudgedaddy,

The bluetooth headset is already implemented...isn't it working for you? I am assuming you did turn on bluetooth before trying the headset?

pudgedaddy said...

ok no , i am not talking about bluetooth "headset" . im talking about bluetooth stereo . aka: bluetooth "headphones" i use a jabra 620S BT head"phones", not head"set" and although they have both headset and BT Stereo profiles as an option, i dont use the headset option. As a result, when those head"phones" are in use no icon shows up. However, when i use my other BT head"set" the "headset" icon shows up for that one. So once my BT headphones are connected, if I were using the default windows icons, it looks like the headset icon but without the mic "boom" at the end of it. Instead the default icon has little music notes inside the headset icon. Hopefully this speels it out a little more. If you have a pair of bluetooth headphones so to your bluetooth profiles and uncheck the hands-free option and leave the bluetooth stereo checked, then re connect the two devices and tell me if you see a headphoners or headset icon

pudgedaddy said...

.....and it's not that the headphones don't work, its that i dont have an indicator letting me know its connected. I kinda have to take that leap of faith. LIke i said i have another BT headset, thats only a headset and when that's connected the headset icon shows up. but theres not an icon impletemented to replace the default windows monochrome BT Stereo icon it shows nothing. Here's a pic of the default BT Stereo Icon.

[IMG]http://i36.photobucket.com/albums/e21/pudgedaddy/headphones.jpg[/IMG]

Mike said...

Rinku,
I love the icon bar. Is there anything that can be done to always use your modified icons. When I am reading email or on a call windows switches back to its default icon bar.
Thanks
Mike

David said...

Rinku, Okay, how exactly do I now go in and make some changes? I want to set the top Iconbar to a dirrerent color than the standard blackish/brownish it currently is..can you explain to me how to go in and make the edit to the iconbar a little better, step by step preferably! thanks much, awesome work you do! David

Henry_Lai said...

Hello Rinku,
Thanks for this great plugin,I am using this plugin on a BenQ E72 with Windows Mobile 6 Standard Version.But I encountered a problem is about battery meter.It always shows red,but my battery are full not empty.Battery charging icon can show on iconbar correctly,but battery meter always show red on iconbar.Could you fix this problem?

Thanks,
Henry Lai

Outerdepth said...

Hey, thanks so much for this great app. I love it. I was wondering where you read the values from in the registry. I would like to do some experimenting, and I am very interested in these. Specifically, I am most curious about the battery plugged-charging icon. Where does it read this value? I have been searching for this info for a long time with no luck, so please get back to me if you can. Thanks

Jeff from MN said...

Absolutely love this. Makes my black theme just perfect. One thing so far, aside from patiently waiting for the possible release of one that also changes the icons when in other windows (start, PIE, etc)...

I'd say roughly 75% of the time, without any correlation that I can see, my signal bars are always grey regardless of how strong my signal is. when like this, it shows all 5 bars, they're just always grey. I'll get the E for the edge signal no problem, I can make calls and use the internet, but the bars stay grey.

Please let me know if you have any thoughts on this...

THanks for all the great, hard work!!

Jeff from MN